What are the browser requirements for accessing the ACPE Online webinar courses?

Microsoft Internet Explorer 6 (Support ending in 2012), Microsoft Internet Explorer 7, Microsoft Internet Explorer 8 (recommended Internet Explorer version), Firefox 3.6, Chrome. The webinars can also be viewed from most handheld devices such as your iPhone, iPad, Android phone or tablet.

FAQ Topic: 
Requirements